EntLib 3.0 && CAB ?

Topics: Enterprise Library Core, General discussion
May 19, 2007 at 5:37 PM
Are enterpriselibrary 3.0 and the Composite UI App Block compatible?

entlib 3.0 uses objectbuilder v 1.0.51206.0 and CAB uses objectbuilder v1.0.51205.0

which one should i reference in my projects? or should i rebuild CAB from source using the newer version.

And as a side-question...
Is it a good idea to reference external binaries this way?
R:\
\---Microsoft
\---Practices
+---CompositeUI
| \---1.0.51205.0
+---EnterpriseLibrary
| +---2.0.0.0
| \---3.0.0.0
\---ObjectBuilder
\---1.0.51205.0
May 19, 2007 at 5:46 PM
Smart Client Software Factory v2 (May 2007) was released today and it uses EntLib 3.1 binaries. So I guess it's better to get CAB from SCSF v2. I think we can expect EntLib 3.1 released here in the next couple of days - http://blogs.msdn.com/blaine/archive/2007/05/18/scsf-may-release-is-ready-amp-wcsf-r1-1-is-coming-soon.aspx

-
Leonid
May 19, 2007 at 7:06 PM
Thanks.... i didn't see that release yet :-)